Are you affected?
Any version below the fixed release for its branch is vulnerable: 8.2.34 is vulnerable, 8.2.35 is fixed. The PHP project lists every installation that serves web requests as affected, including PHP-FPM, Apache mod_php and php-cgi.
Then check your scanner for findings on CVE-2026-109618 and CVE-2026-109619:
- A finding for either CVE: vulnerable.
- Recent credentialed scan, no finding: likely fixed.
- No recent credentialed scan: unknown. Treat it as vulnerable until it’s scanned.
What ThreatAware can do on your plan
By vulnerability scanner we mean any tool that reports vulnerabilities on your devices, such as Microsoft Defender Vulnerability Management, Qualys, Tenable or Rapid7.
Find affected devices
1. Find the gaps in your scanner’s coverage
The question to answer is: how many of your servers and workstations aren’t in your scanner at all, or are in it but not being scanned properly?- Connect
- Discover
- Protect
2. Spot likely PHP installs with software inventory
Software inventory gives you a rough picture of where PHP is installed, which helps you decide what to look at first.Treat it as a guide, not a vulnerability check. A software query only matches where a connected tool lists PHP as installed software, so many installs never appear (see Blind spots). Software data refreshes about every two days, so a device patched yesterday can still show the old version. The query bar is case sensitive, so the queries below check
php, Php and PHP. Confirm with your scanner or the server’s owner before you tell anyone it’s vulnerable.Names PHP is reported under
Names PHP is reported under
To catch all of them:
*Php* also matches developer tools such as PhpStorm; ignore devices that only have those. In Software Inventory, search for php and each stack name, and expand a product to see each version and its device count.Checking versions
Checking versions
The version shown is reliable for end-of-life branches and for php.net builds, which most Windows installs use. It isn’t reliable for Linux distribution packages: distributions backport fixes without changing the version number, so a fixed package can still report something like 8.2.20.The query language matches with wildcards only, so it can’t ask for “version below 8.4.27”. To list devices with PHP that aren’t on a fixed release:If PHP 8.5.13, 8.4.28 or later comes out, add it to the query.
Track the fix
- Run a query from step 1 or step 2 and click Track View. Choose Snapshot and set a Deadline. See Tracked Views.
- In Action Center, build a flow triggered by that tracked view to email the device owners, or open tickets in ServiceNow or another tool with an HTTP request step.
- Save the query as a view and send a daily Scheduled Report of it to your security lead until it’s empty.
Blind spots
Expect a lot of PHP that ThreatAware can’t see, including on servers it knows about. If another tool shows PHP on a server that the queries above don’t match, it’s usually one of these:
To see which applies, open the server in Devices, check which tools report on it under Vitals, then click Details and Software to see the software list ThreatAware has for it. For anything ThreatAware can’t see, use your scanner’s findings, ask the teams that run it, or check the vendor’s advisories for appliances.
ThreatAware can’t apply the temporary mitigations or check for signs of compromise. Those belong to your EDR and incident response teams.
Sources
- NVD: CVE-2026-109618 (out-of-memory handling) and CVE-2026-109619 (stale request state), both leading to remote code execution
- Coverage: Help Net Security, The Hacker News, Huntress